FC5 error: Deprecated pam_stack module called from service “imap”

FC5 error: Deprecated pam_stack module called from service “imap”

FC5 error: Deprecated pam_stack module called from service “imap” 150 150 Roderick Derks

Problem 

After installing FC5 and configuring the first in the LogWatch daily report gave me tis error (from the /var/log /security logfile):

——————— sasl auth daemon Begin ————————

**Unmatched Entries**

Deprecated pam_stack module called from service "imap"
Deprecated pam_stack module called from service "imap"

Solution

It appears that from FC5 onwards, lines like this in PAM configuration files:
auth required pam_stack.so service=system-auth
account required pam_stack.so service=system-auth

Should be replaced by:
auth include system-auth
account include system-auth

The error message will not be shown anymore, now a correct logentry will be added:
 runuser: pam_unix(runuser:session): session opened for user cyrus by (uid=0)

Roderick Derks

Liefhebber van fietsen, van het oplossen van IT puzzels, en van het delen van informatie om anderen te helpen.

All stories by:Roderick Derks

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Your Name (required)

Your Email (required)

Subject

Your Message

Your Name (required)

Your Email (required)

Subject

Your Message